	<!doctype html>
	<!--[if !IE]>
	<html class="no-js non-ie" lang="en-US"> <![endif]-->
	<!--[if IE 7 ]>
	<html class="no-js ie7" lang="en-US"> <![endif]-->
	<!--[if IE 8 ]>
	<html class="no-js ie8" lang="en-US"> <![endif]-->
	<!--[if IE 9 ]>
	<html class="no-js ie9" lang="en-US"> <![endif]-->
	<!--[if gt IE 9]><!-->
<html class="no-js" lang="en-US"> <!--<![endif]-->
	<head>

		<meta charset="UTF-8"/>
		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<link rel="profile" href="http://gmpg.org/xfn/11"/>
		<link rel="pingback" href="https://ehsanakhgari.org/xmlrpc.php"/>

		<title>Quantum Flow Engineering Newsletter #21 &#8211; Ehsan Akhgari</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ehsan Akhgari &raquo; Feed" href="https://ehsanakhgari.org/feed" />
<link rel="alternate" type="application/rss+xml" title="Ehsan Akhgari &raquo; Comments Feed" href="https://ehsanakhgari.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Ehsan Akhgari &raquo; Quantum Flow Engineering Newsletter #21 Comments Feed" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ehsanakhgari.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='simple-payments-css'  href='https://ehsanakhgari.org/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-style-css'  href='https://ehsanakhgari.org/wp-content/themes/responsive/core/css/style.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-media-queries-css'  href='https://ehsanakhgari.org/wp-content/themes/responsive/core/css/responsive.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://ehsanakhgari.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://ehsanakhgari.org/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://ehsanakhgari.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/themes/responsive/core/js/responsive-modernizr.min.js?ver=2.6.1'></script>
<link rel='https://api.w.org/' href='https://ehsanakhgari.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ehsanakhgari.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ehsanakhgari.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Quantum Flow Engineering Newsletter #20' href='https://ehsanakhgari.org/blog/2017-08-18/quantum-flow-engineering-newsletter-20' />
<meta name="generator" content="WordPress 4.8.1" />
<link rel="canonical" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21" />
<link rel='shortlink' href='https://wp.me/p2HZDv-pM' />
<link rel="alternate" type="application/json+oembed" href="https://ehsanakhgari.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fehsanakhgari.org%2Fblog%2F2017-08-25%2Fquantum-flow-engineering-newsletter-21" />
<link rel="alternate" type="text/xml+oembed" href="https://ehsanakhgari.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fehsanakhgari.org%2Fblog%2F2017-08-25%2Fquantum-flow-engineering-newsletter-21&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
	<script>
		jQuery(document).ready(function(){
		var copyright_text = "";
		var cyberchimps_link = "";
		var siteurl = "https://ehsanakhgari.org"; 
		if(copyright_text == "")
		{
			jQuery(".copyright #copyright_link").text(" "+"Default copyright text");
		}
		else{ 
			jQuery(".copyright #copyright_link").text(" "+copyright_text);
		}
		jQuery(".copyright #copyright_link").attr('href',siteurl);
		if(cyberchimps_link == 1)
		{
			jQuery(".powered").css("display","block");
		}
		else{
			jQuery(".powered").css("display","none");
		}
		});
	</script>
<!-- We need this for debugging -->
<!-- Responsive 3.0 -->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Quantum Flow Engineering Newsletter #21" />
<meta property="og:url" content="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21" />
<meta property="og:description" content="We&#8217;re now about mid-way through the Firefox 57 development cycle.  The progress of Quantum Flow bugs has been steady, we now have 65 open [qf:p1] bugs at the time of this writing and 283 fixe…" />
<meta property="article:published_time" content="2017-08-25T06:57:49+00:00" />
<meta property="article:modified_time" content="2017-08-25T06:57:49+00:00" />
<meta property="og:site_name" content="Ehsan Akhgari" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
	</head>

<body class="post-template-default single single-post postid-1598 single-format-standard">

<div id="container" class="hfeed">

	<div class="skip-container cf">
		<a class="skip-link screen-reader-text focusable" href="#content">&darr; Skip to Main Content</a>
	</div><!-- .skip-container -->
	<div id="header" role="banner">

		
		
		
		
		
			<div id="logo">
				<span class="site-name"><a href="https://ehsanakhgari.org/" title="Ehsan Akhgari" rel="home">Ehsan Akhgari</a></span>
				<span class="site-description"></span>
			</div><!-- end of #logo -->

		
				<div class="main-nav"><ul id="menu-categories" class="menu"><li id="menu-item-156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-156"><a href="/">Home</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-154"><a title=" " href="https://ehsanakhgari.org/category/blog">Blog</a></li>
<li id="menu-item-150" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150"><a title=" " href="https://ehsanakhgari.org/category/article">Articles</a>
<ul  class="sub-menu">
	<li id="menu-item-157" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157"><a title=" " href="https://ehsanakhgari.org/category/article/visual-c">Visual C++</a></li>
	<li id="menu-item-158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158"><a title=" " href="https://ehsanakhgari.org/category/article/php">php</a></li>
	<li id="menu-item-159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159"><a title=" " href="https://ehsanakhgari.org/category/article/miscellaneous">Miscellaneous</a></li>
</ul>
</li>
<li id="menu-item-155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-155"><a title=" " href="https://ehsanakhgari.org/category/talks">Talks</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232"><a href="/contact">Contact</a></li>
</ul></div>
		
		
	</div><!-- end of #header -->

	<div id="wrapper" class="clearfix">

<div id="content" class="grid col-620" role="main">

	<div class="breadcrumb-list" xmlns:v="http://rdf.data-vocabulary.org/#"><span class="breadcrumb" typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://ehsanakhgari.org/">Home</a></span> <span class="chevron">&#8250;</span> <span class="breadcrumb" typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://ehsanakhgari.org/category/blog">Blog</a></span> <span class="chevron">&#8250;</span> <span class="breadcrumb-current">Quantum Flow Engineering Newsletter #21</span></div>
	
		
						<div id="post-1598" class="post-1598 post type-post status-publish format-standard hentry category-blog tag-mozilla tag-planet tag-quantumflow">
				
				
	<h1 class="entry-title post-title">Quantum Flow Engineering Newsletter #21</h1>

<div class="post-meta">
	<span class="meta-prep meta-prep-author posted">Posted on </span><a href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21" title="Quantum Flow Engineering Newsletter #21" rel="bookmark"><time class="timestamp updated" datetime="2017-08-25T06:57:49+00:00">August 25, 2017</time></a><span class="byline"> by </span><span class="author vcard"><a class="url fn n" href="https://ehsanakhgari.org/author/ehsanak" title="View all posts by ehsan"><span class="author-gravtar"><img alt='' src='https://secure.gravatar.com/avatar/5aef682fbfd7590b9d85d6e8dbab10eb?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5aef682fbfd7590b9d85d6e8dbab10eb?s=64&amp;d=mm&amp;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></span>ehsan</a></span>
			<span class="comments-link">
		<span class="mdash">&mdash;</span>
			<a href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21#respond">No Comments &darr;</a>		</span>
	</div><!-- end of .post-meta -->

				<div class="post-entry">
					<p>We&#8217;re now about mid-way through the Firefox 57 development cycle.  The <a href="https://cpeterso.github.io/burndown/?whiteboard=[qf:p1]&amp;since=2017-03-01">progress</a> of Quantum Flow bugs has been steady, we now have 65 open [qf:p1] bugs at the time of this writing and 283 fixed bugs.  There are still more bugs being flagged for triage constantly.  I haven&#8217;t really spoken much about the triage process lately and the reason is that it has been working as per usual and the output should be fairly visible to everyone through our <a href="https://charts.mozilla.org/quantum/blockers.html">dashboard</a>.</p>
<p>On the Speedometer front, if you are watching the main <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1339557">tracking</a> <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1245279">bugs</a>, the addition of new dependencies every once in a while should be an indication that we are still profiling the benchmark looking for more areas where we can think of speedup opportunities.  Finding these new opportunities has become more and more difficult as we have been fixing more and more of the existing performance issues, which is exactly what you would expect working on improving the performance of Firefox on such a benchmark workload.  Of course, we still have ongoing work in the existing dependency tree (which is quite massive at this point) so more improvements should hopefully arrive as we keep landing more fixes on this front.</p>
<p>I realize that I have been quite inconsistent in having a performance story section in these newsletters, and I hope the readers will forgive me for that!  🙂  But these past couple of weeks, Jan de Mooij&#8217;s continued effort on <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1389510">removing getProperty/setProperty JSClass hooks</a> from SpiderMonkey made me want to write a few sentences about some useful lessons we have learned from performance measurements which can hopefully be used in the future when designing new components/subsystems.  Often times when we are thinking of how to design software, one can think of many extension points at various levels which consumers of the code can plug into in order to customize behavior.  But many such extension points come at a <em>runtime cost</em>.  The cost is usually quite small, we may need to consume some additional memory to store more state, we may need to branch on some conditions, we may need to perform some more indirect/virtual calls, etc.  The problem is that usually this cost is extremely small, and it can easily go unnoticed.  But this can often happen in many places, and over time performance issues like this tend to creep in and hide in corners.  Of course, usually when these extension points are added there are good reasons for creating them, but it may be a good idea to ask questions like &#8220;Is this mechanism too high level of a solution for this specific problem?&#8221;, &#8220;Is the runtime cost paid for this over the years to come justified to solve the issue at hand?&#8221;, &#8220;Could this issue be solved by adding an extension point in a more specialized place where the added cost would only affect a subset of the consumers?&#8221;, etc.  The reality of software engineering is that in a lot of cases we need to trade off having a generic, extensible architecture in our code versus having efficient code, so if you end up choosing extensibility, it&#8217;s a good idea to ensure you have had the performance aspects in mind.  It&#8217;s even better if you document the performance concerns!</p>
<p>And since we touched on this, now may be a good time to also take a quick moment to call out another issue which I have seen come up on some of the performance issues we have been looking into in the past few months.  That is the <em>death by a thousand cuts performance problems</em>.  In my experience, many of the performance issues that we need to deal with, when profiled turn out to be caused by only a few really badly performing parts of the code, or at least are due to a few underlying causes.  But we also have no shortage of the other kind of performance issues which are honestly much more difficult to deal with.  The way things work out in the opposite scenario is you look at a profile from the badly performing case, you narrow down on the section of the profile which demonstrates the issue, and no matter how hard you squint, there are no major issues to be fixed.  Rather, the profile shows <em>many</em> individual issues each contributing to a tiny portion of the time spent during the workload.  These performance issues are much harder to analyze (since there are typically many ways you can start approaching it and it&#8217;s unclear where is a good place to start) and they take a much longer time to result in measurable improvements, as you&#8217;d need to fix quite a few issues in order to be able to measure the resulting improvement.  For a good example of this, please look at the saga of <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1346723">optimizing setting the value property of input elements</a>.  This project has been going on for a few months now, and during this time the workload has been made faster by more than an order of magnitude, but still if you look at each of the individual patches that have landed, they look like micro-optimizations, and that&#8217;s for a good reason, because they <em>are</em>.  But overall they add up to significant improvements.</p>
<p>Before closing, it is worth mentioning that the ongoing performance work isn&#8217;t suddenly going to stop with the release of Firefox 57!  In fact we have large performance projects which are going to get ready after Firefox 57, and that is a good thing, since I view Firefox 57 not as an ultimate performance goal, but as a solid performance foundation for us to start building upon.  A great example is the <a href="https://wiki.mozilla.org/Platform/GFX/Quantum_Render">Quantum Render</a> project which has been going on for a long time now.  This project aims to integrate the <a href="https://github.com/servo/webrender">WebRender</a> component of <a href="https://servo.org/">Servo</a> into Firefox.  This project now has an <a href="https://mozillagfx.wordpress.com/category/wr-newsletter/">exciting newsletter</a>, and the first two issues are out!  Please take a moment to check it out.</p>
<p>And now it is time to take a moment to thank the contributions of those who helped make Firefox faster last week.  As usual I hope I&#8217;m not forgetting any names!</p>
<ul>
<li>Evelyn Hung made it so that when we tell the content process to load a URI, <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1383299">we first initiate a speculative connection in the parent process</a> so that we don’t have to wait for the content process to request network access for the connection to be set up.  In a similar vein, Evelyn also made us <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1355451">initiate a speculative connection upon the mousedown event on an awesomebar result entry</a> to start setting up the network connection even faster when using the mouse to pick an awesomebar result.</li>
<li>Paolo Amadini <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391576">made FileUtils.getFile() not do main-thread IO for the common case</a>.  You may remember some fixes to callers of this function were mentioned in the previous newsletters to avoid this pattern of main-thread IO, and this fix will hopefully address this issue for most of the remaining callers. Paolo also <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1358792">got rid of some reflows</a> we were doing when opening up the AwesomeBar panel.</li>
<li>prasanthp96 <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1383088">deferred reading several preferences</a> to reduce their impact on startup performance.</li>
<li>Botond Ballo enabled support for <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1390247">asynchronous autoscrolling on the Nightly channel</a>.</li>
<li>André Bargull <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391304">inlined IsCallable when called from MIRType::Value</a>.</li>
<li>Olli Pettay <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391423">added a nursory to the cycle collector purple buffer</a> in order to speed up AddRef/Release calls to cycle collectible objects on the main thread.  He also <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1390402">added a faster variant of TextEditor::GetDocumentIsEmpty()</a> in order to speed up setting the value property of input elements.</li>
<li>Ming-Chou Shih <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1361067">enabled coalescing mousemove events to once per refresh cycle</a>.  This feature helps performance by dispatching fewer mousemove events on pages which have expensive mousemove handlers, and is <a href="https://www.chromestatus.com/feature/6192761317359616">shipped in Chrome</a> recently.  It is currently <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1392876">disabled</a> behind a preference for testing.</li>
<li>Kris Maglione <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1389840">cached some extension manifest data in the startup cache</a>.  He also <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391110">converted FrameLoader bindings to WebIDL</a> for improved performance of the JS code going through these bindings to access the underlying C++ code.  He also <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391405">made the WebExtension schema normalization code faster</a>.  Last but not least, Kris <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1356334">added a UI for notifying the user about long running WebExtension content scripts and provide the option to stop them</a>, similar to the existing UI we have for long running content scripts.  While this isn&#8217;t strictly a performance improvement in itself, it is worthy of mention here because it allows the user to interrupt a badly behaving WebExtension content script causing performance issues.</li>
<li>Masayuki Nakano <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391165">optimized TextEditRules::CollapseSelectionToTrailingBRIfNeeded()</a>.</li>
<li>Jessica Jong made sure we <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1390342">skip the potentially expensive pattern matching code when validating input elements if the element has no pattern attribute set</a>.</li>
<li>Jan de Mooij <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1391611">devirtualized MNode::kind()</a> and <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1392530">MDefinition::op()</a>.</li>
<li>Bao Quan <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1388664">moved _saveStateAsync to the idle event queue</a>.</li>
<li>John Dai ensured that we <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1392790">avoid processing custom element reactions stack when web components are disabled</a>.</li>
<li>Makoto Kato <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1348073">enabled lazy frame construction in editable regions of HTML documents</a>.  The original <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=502937">lazy frame construction optimization</a> was enabled in 2010 and shipped in Firefox 4 but it never covered editable sections of HTML documents such as contents of input and textarea textboxes as well as contenteditable elements until now.</li>
<li>Doug Thayer <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1389443">made it so that we avoid some main thread IO</a> when registering MIME-type handlers on start-up.</li>
</ul>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1598" class="share-twitter sd-button share-icon" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1598" class="share-facebook sd-button share-icon" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-1598" class="share-google-plus-1 sd-button share-icon" href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li></ul></div></div></div>
					
									</div><!-- end of .post-entry -->

				<div class="navigation">
					<div class="previous">&#8249; <a href="https://ehsanakhgari.org/blog/2017-08-18/quantum-flow-engineering-newsletter-20" rel="prev">Quantum Flow Engineering Newsletter #20</a></div>
					<div class="next"></div>
				</div><!-- end of .navigation -->

				
	<div class="post-data">
		Posted in <a href="https://ehsanakhgari.org/category/blog">Blog</a>		Tagged with: <a href="https://ehsanakhgari.org/tag/mozilla" rel="tag">mozilla</a>, <a href="https://ehsanakhgari.org/tag/planet" rel="tag">planet</a>, <a href="https://ehsanakhgari.org/tag/quantumflow" rel="tag">quantumflow</a><br />	</div><!-- end of .post-data -->

<div class="post-edit"></div>
							</div><!-- end of #post-1598 -->
			
						




	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/2017-08-25/quantum-flow-engineering-newsletter-21#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=40037709&#038;postid=1598&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.2.1&#038;sig=08bf4bab952bdcbf0899ccbdbe9290ac94d02658#parent=https%3A%2F%2Fehsanakhgari.org%2Fblog%2F2017-08-25%2Fquantum-flow-engineering-newsletter-21" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		

			
		
</div><!-- end of #content -->


	<div id="widgets" class="grid col-300 fit" role="complementary">
		
		<div id="search-2" class="widget-wrapper widget_search"><form method="get" id="searchform" action="https://ehsanakhgari.org/">
	<label class="screen-reader-text" for="s">Search for:</label>
	<input type="text" class="field" name="s" id="s" placeholder="search here &hellip;" />
	<input type="submit" class="submit" name="submit" id="searchsubmit" value="Go" />
</form>
</div>		<div id="recent-posts-2" class="widget-wrapper widget_recent_entries">		<div class="widget-title"><h3>Recent Posts</h3></div>		<ul>
					<li>
				<a href="https://ehsanakhgari.org/blog/2017-08-25/quantum-flow-engineering-newsletter-21">Quantum Flow Engineering Newsletter #21</a>
						</li>
					<li>
				<a href="https://ehsanakhgari.org/blog/2017-08-18/quantum-flow-engineering-newsletter-20">Quantum Flow Engineering Newsletter #20</a>
						</li>
					<li>
				<a href="https://ehsanakhgari.org/blog/2017-08-11/quantum-flow-engineering-newsletter-19">Quantum Flow Engineering Newsletter #19</a>
						</li>
					<li>
				<a href="https://ehsanakhgari.org/blog/2017-08-04/quantum-flow-engineering-newsletter-18">Quantum Flow Engineering Newsletter #18</a>
						</li>
					<li>
				<a href="https://ehsanakhgari.org/blog/2017-07-28/quantum-flow-engineering-newsletter-17">Quantum Flow Engineering Newsletter #17</a>
						</li>
				</ul>
		</div>		<div id="recent-comments-2" class="widget-wrapper widget_recent_comments"><div class="widget-title"><h3>Recent Comments</h3></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">ehsan</span> on <a href="https://ehsanakhgari.org/blog/2017-08-18/quantum-flow-engineering-newsletter-20#comment-3595">Quantum Flow Engineering Newsletter #20</a></li><li class="recentcomments"><span class="comment-author-link">mayank</span> on <a href="https://ehsanakhgari.org/blog/2017-08-18/quantum-flow-engineering-newsletter-20#comment-3594">Quantum Flow Engineering Newsletter #20</a></li><li class="recentcomments"><span class="comment-author-link">ehsan</span> on <a href="https://ehsanakhgari.org/blog/2017-08-04/quantum-flow-engineering-newsletter-18#comment-3593">Quantum Flow Engineering Newsletter #18</a></li><li class="recentcomments"><span class="comment-author-link">ehsan</span> on <a href="https://ehsanakhgari.org/blog/2017-08-11/quantum-flow-engineering-newsletter-19#comment-3592">Quantum Flow Engineering Newsletter #19</a></li><li class="recentcomments"><span class="comment-author-link">Bill Wood</span> on <a href="https://ehsanakhgari.org/blog/2017-08-11/quantum-flow-engineering-newsletter-19#comment-3591">Quantum Flow Engineering Newsletter #19</a></li></ul></div><div id="archives-2" class="widget-wrapper widget_archive"><div class="widget-title"><h3>Archives</h3></div>		<ul>
			<li><a href='https://ehsanakhgari.org/2017/08'>August 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/07'>July 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/06'>June 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/05'>May 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/04'>April 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/03'>March 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2017/01'>January 2017</a></li>
	<li><a href='https://ehsanakhgari.org/2016/04'>April 2016</a></li>
	<li><a href='https://ehsanakhgari.org/2016/01'>January 2016</a></li>
	<li><a href='https://ehsanakhgari.org/2015/12'>December 2015</a></li>
	<li><a href='https://ehsanakhgari.org/2015/09'>September 2015</a></li>
	<li><a href='https://ehsanakhgari.org/2015/07'>July 2015</a></li>
	<li><a href='https://ehsanakhgari.org/2015/04'>April 2015</a></li>
	<li><a href='https://ehsanakhgari.org/2015/01'>January 2015</a></li>
	<li><a href='https://ehsanakhgari.org/2014/12'>December 2014</a></li>
	<li><a href='https://ehsanakhgari.org/2014/06'>June 2014</a></li>
	<li><a href='https://ehsanakhgari.org/2012/12'>December 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/11'>November 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/10'>October 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/09'>September 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/08'>August 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/06'>June 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/04'>April 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2012/01'>January 2012</a></li>
	<li><a href='https://ehsanakhgari.org/2011/11'>November 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/10'>October 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/09'>September 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/08'>August 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/06'>June 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/05'>May 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/04'>April 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/03'>March 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/02'>February 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2011/01'>January 2011</a></li>
	<li><a href='https://ehsanakhgari.org/2010/09'>September 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/06'>June 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/05'>May 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/04'>April 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/03'>March 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/02'>February 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2010/01'>January 2010</a></li>
	<li><a href='https://ehsanakhgari.org/2009/12'>December 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/11'>November 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/10'>October 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/06'>June 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/05'>May 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/02'>February 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2009/01'>January 2009</a></li>
	<li><a href='https://ehsanakhgari.org/2008/12'>December 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/11'>November 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/10'>October 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/09'>September 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/08'>August 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/07'>July 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/06'>June 2008</a></li>
	<li><a href='https://ehsanakhgari.org/2008/05'>May 2008</a></li>
		</ul>
		</div><div id="categories-2" class="widget-wrapper widget_categories"><div class="widget-title"><h3>Categories</h3></div>		<ul>
	<li class="cat-item cat-item-38"><a href="https://ehsanakhgari.org/category/blog" >Blog</a>
</li>
	<li class="cat-item cat-item-45"><a href="https://ehsanakhgari.org/category/extension" >Extension</a>
</li>
	<li class="cat-item cat-item-42"><a href="https://ehsanakhgari.org/category/article/miscellaneous" >Miscellaneous</a>
</li>
	<li class="cat-item cat-item-19"><a href="https://ehsanakhgari.org/category/article/php" >php</a>
</li>
	<li class="cat-item cat-item-40"><a href="https://ehsanakhgari.org/category/talks" >Talks</a>
</li>
	<li class="cat-item cat-item-41"><a href="https://ehsanakhgari.org/category/article/visual-c" >Visual C++</a>
</li>
		</ul>
</div><div id="meta-2" class="widget-wrapper widget_meta"><div class="widget-title"><h3>Meta</h3></div>			<ul>
						<li><a href="https://ehsanakhgari.org/wp-login.php">Log in</a></li>
			<li><a href="https://ehsanakhgari.org/feed">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://ehsanakhgari.org/comments/feed">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div>
			</div><!-- end of #widgets -->
</div><!-- end of #wrapper -->
</div><!-- end of #container -->

<div id="footer" class="clearfix" role="contentinfo">
	
	<div id="footer-wrapper">

		
		<div class="grid col-940">

			<div class="grid col-540">
							</div><!-- end of col-540 -->

			<div class="grid col-380 fit">
				<ul class="social-icons"><li class="twitter-icon"><a href="https://twitter.com/ehsanakhgari"><img src="https://ehsanakhgari.org/wp-content/themes/responsive/core/icons/twitter-icon.png" width="24" height="24" alt="Twitter"></a></li><li class="linkedin-icon"><a href="http://www.linkedin.com/in/ehsanakhgari"><img src="https://ehsanakhgari.org/wp-content/themes/responsive/core/icons/linkedin-icon.png" width="24" height="24" alt="LinkedIn"></a></li></ul><!-- .social-icons -->			</div><!-- end of col-380 fit -->

		</div><!-- end of col-940 -->
		
		<div class="grid col-300 copyright">
			&copy; 2017<a id="copyright_link" href="https://ehsanakhgari.org/" title="Ehsan Akhgari">
				Ehsan Akhgari			</a>
		</div><!-- end of .copyright -->

		<div class="grid col-300 scroll-top"><a href="#scroll-top" title="scroll to top">&uarr;</a></div>

		<div class="grid col-300 fit powered">
			<a href="http://cyberchimps.com/responsive-theme/" title="Responsive Theme" rel="noindex, nofollow">Responsive Theme</a>
			powered by <a href="http://wordpress.org/" title="WordPress">
				WordPress</a>
		</div><!-- end .powered -->

	</div><!-- end #footer-wrapper -->

	</div><!-- end #footer -->

	<div style="display:none">
	<div class="grofile-hash-map-5aef682fbfd7590b9d85d6e8dbab10eb">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/ehsanakhgari.org\/blog\/2017-08-25\/quantum-flow-engineering-newsletter-21":1598};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/blog/2017-08-25/quantum-flow-engineering-newsletter-21" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://ehsanakhgari.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201734'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/themes/responsive/core/js/responsive-scripts.min.js?ver=1.2.6'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/themes/responsive/core/js/jquery.placeholder.min.js?ver=2.0.7'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ehsanakhgari.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.2.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=40037709&postid=1598&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.2.1&sig=08bf4bab952bdcbf0899ccbdbe9290ac94d02658#parent=https%3A%2F%2Fehsanakhgari.org%2Fblog%2F2017-08-25%2Fquantum-flow-engineering-newsletter-21" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=40037709&postid=1598&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.2.1&sig=08bf4bab952bdcbf0899ccbdbe9290ac94d02658#parent=https%3A%2F%2Fehsanakhgari.org%2Fblog%2F2017-08-25%2Fquantum-flow-engineering-newsletter-21";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201734.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.2.1',blog:'40037709',post:'1598',tz:'0',srv:'ehsanakhgari.org'} ]);
	_stq.push([ 'clickTrackerInit', '40037709', '1598' ]);
</script>
</body>
</html>
